Vamos por Beryl en Debian Sid

enero 14, 2007 at 2:23 am (Instalaciones)

Después de un par de intentos fallidos de instalar Beryl en un AMD Sempron 2400+, 512 Mb de Ram y una NVIDIA GeForce FX 5200 de 128 Mb que tenia Debian Sid, volví a intentarlo pero en el laptop

AMD Sempron Mobile 3400+
512 Mb Ram
NVIDIA GeForce Go 6150 hasta con 128Mb de memoria (Compartida)

Googleando por ahí encontré un sitio donde habían instalado Beryl SVN en una maquina parecida a esta asi que seguí la guía y todo funciono correctamente, asi que estos son los pasos…

Fuente : CodBlog.com.ar -> AIGLX/Beryl en Debian GNU/Linux (nVidia!)

0. Recomendable actualizar el sitema

# apt-get update
# apt-get upgrade
# apt-get dist-upgrade

1. Activar la aceleración gráfica, eso ya lo hicimos anteriormente, la guía aqui

2. Instalar Beryl, loguearse como root y agregar las siguientes lineas en /etc/apt/sources.list

# Beryl
deb http://download.tuxfamily.org/3v1deb debian-unstable beryl-svn

Guardar los cambios y actualizar la cache de apt y luego instalar los paquetes necesarios

# apt-get update
# aptitude install beryl beryl-core beryl-dbus beryl-dev beryl-manager beryl-plugins beryl-plugins-data beryl-settings libberylsettings-dev libberylsettings0 beryl-settings-bindings emerald-themes

3. Configuración de /etx/X11/xorg.conf

La sección “Device” deberá quedar algo así:

Section "Device"
Identifier "Algún nombre"
Driver "nvidia"
Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"
Option "HWCursor" "true"
EndSection

En la sección “Screen” agregar lo siguiente antes de las sub-secciones:

Option "AddARGBGLXVisuals" "true"

Y por ultimo al final del archivo agregar:

Section "Extensions"
Option "Composite" "Enable"
EndSection

4. Reiniciar el servidor grafico (CTRL+ALT+Backspc) y por ultimo inicial beryl:

# beryl-manager

Y listo, ya está funcionando Beryl SVN, si queremos que se inicie automáticamente Beryl al iniciar el Gnome debemos abrir Escritorio -> Preferencias -> Sesiones -> Programas al Inicio y agregar el siguiente comando:

# beryl-manager

Ahora solo queda jugar!!!!!!

Anuncios

3 comentarios

  1. Geo said,

    ¿Y qué tal te ha funcionado? En mi PC de escritorio con un Pentium IV @ 3GHz y una Radeon 9200 se alenta un tanto el sistema, todavía es posible trabajar pero con pocas aplicaciones, aunque por lo menos le he podido dar una probadita a Beryl (estoy con Ubuntu), sé que el problema es mi tarjeta gráfica, pero por lo pronto no puedo actualizarla :).

    Pero bueno, estoy interesado en comprar una laptop, y me gustaría correrla con Ubuntu y Beryl decentemente, por eso es que ando indagando :).

  2. jpolako said,

    mmmm, yo en mi PC de escritorio tengo un AMD 2400+, 512 Ram y nVidia GeForce 5200 de 120 Mb y corre mas o menos, se alenta un poco, le he instalado debian SID, ubuntu Dapper Drake, Edgy Eft y openSUSE 10.2, en todos ha funcionado mas o menos, aunque bien…..

    El problema es que con ciertas aplicaciones el uso de RAM aumenta demasiado y como siempre he utilizado versiones actualizadas ha dado ciertas fallas, pero todo bien con mi PC de escritorio…

    Pero con mi laptop, que lo compre mas para trabajar, ya que soy ( casi falta poco ) Ingeniero en Computacion, he tenido muchos problemas, pero se debe al laptop, no a los programas, no se si sera toda la linea v31xx pero el v3117la es un atado de mañas, incluso con los drivers de windows me ha molestado, jajajajaja, el problema se debe a que las imagenes del kernel que traen compiladas los sistemas no son las adecuadas para esta arquitectura, si al instalar beryl he perdido las terminales virtuales ( ttyX , CTRL + F1,2,3,4,5,6) se ven negras, tuve que cambiar la resolucion de estas para poder verlas, lo que intente es recompilar el kernel, pero he tenido problemas jajajajajaja, lo que tambien hice fue cambiar el splash del inicio del kernel, pronto posteare como, jejejeje, estoy con poco tiempo….

    pero en general he estado un poco descontento con el v3117la con debian….
    es lo que te puedo decir, aunque otras lineas de HP-Comnpaq funcionan de maravilla, jejejejej

  3. aleks said,

    Hola bueno yo teno esa lap y seguido todos los pasos de hecho cuando hago el apt e instalo todos lo requerido :

    (# apt-get update
    # aptitude install beryl beryl-core beryl-dbus beryl-dev beryl-manager beryl-plugins beryl-plugins-data beryl-settings libberylsettings-dev libberylsettings0 beryl-settings-bindings emerald-themes)

    me marca un error con la libc6 (no es compatible con algunos paquetes (necesta una version mayor de libc6) y bueno para eso le pongo en /etc/apt/sources.list unoas direcciones de debian inestable ( como lo marca en la pagina ke tomaste como referencia : Fuente : CodBlog.com.ar -> AIGLX/Beryl en Debian GNU/Linux (nVidia!)

    y bueno despues de eso si se instala y cuando,lo jalo se pone todo blanco y nada de nada. te paso algo similar?

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión /  Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión /  Cambiar )

w

Conectando a %s

A %d blogueros les gusta esto: